Loading...

Tank-O3 - in action

Tank-O3 - in action

After the the tank-O3 installation prior to our Scandinavian tour for 2019. The tank was filled and the system activated over our 24V DC setup in the living unit. So far so good and all seemed to work and function as aspected.

However just 3 day's prior to our departure I notices a strange smell in the under bed storage of the living unit, where the watertank is installed. Upon inspection I noticed a red LED on the Tank-O3 controller unit, and noticed that the unit was hot. Most likely hotter then expected and intended. So a quick call on Sunday afternoon with Geert from Tank-O3 describing the scenario, made him decide to send me a new controller unit asap so we could depart on time. Talking about service !

With the new controller unit installed, the LED was green again. No funny smells, and the system was producing Ozone as expected again.

After two days into our trip on a German camping I was doing a routine check on all the systems and noticed a red LED on the controller unit again.... I disassembled the Ozon cell from the tank and noticed a huge white deposit on the cell core. I had already disconnected the system from it's DC source, and as it was weekend I took some pictures and shared them over Whats-App with Geert informing him about the situation...

Quickly after sharing my information Geert leaped into action. And despite the bad 3G cellular signal and no WiFi connection we managed to get hold of each other somewhere during that Sunday afternoon.

Could the problem be the 24V DC perhaps... ?

As this now was the second controller unit providing an error, getting somewhat hot again we decided to see if I could arrange a 12V DC source to supply the controller. Luckely I had installed a 24-12DC step-down converter last year for possible accessories in the truck cabin. Till now it had been idling in the glove compartment, so I could re-use it for the controller to run on 12V.

With the 24-12 stepdown voltage converter in it's new position and the controller unit connected it still provided a RED error LED. But the controller was significantly cooler running on 12V DC as previously on the 24V DC. It was producing Ozone in reasonable amounts again with a replaced cell core. So I decided to go ahead and keep in contact with Tank-O3 over the rest of our journey, to see, learn and hopefully solve the problem once back in the Netherlands.

Now checking the system on a daily basis I noticed a more 'expected behaviour' of the deposit rate on the cell core. A periodic cleaning interval of ~10-14 days is to be expected on 12V systems. That got me to think..

As I have experience in galvanic operations during my time as a CD/DVD production engineer. And the Tank-O3 controller unit actually being a galvanic controller unit. The rate of deposit is reversely proportional to the square or the applied current. So with 24 in stead of 12V the expected maintenance interval would be 1/4 of 10-14 days... almost matching the time at which I found the issue while on the road. And more important the now expected deposit rate running 12V, should yield the normal 10-14 days again. Which it did !

To clean the cell core you simply place it into a weal acid solution like citric acid or table vinegar. We went on the hunt in local supermarkets of Denmark and bought some vinegar, the type you use for salads, in a LIDL. Which does a perfect job of cleaning the cell core immersed in the solution for 15-20 minutes.

With each tank fill we could clearly smell the distinct Ozone smell of the above waterlevel gass being expelled over the tank vent on the side of our habitation box.

24V or 12V ?

As I prefer to have all systems on 24V, the native DC source of the truck and the living unit. Tank-O3 generously provided me with a different cell core. Having 3 cell cores, the 24V DC current is now again proportionally over the active surface, keeping the deposition rate in line with the 10-14 day's maintenance interval.